DHCP FAILED APIPA IS USED
Hi to all,
In a Cisco packet tracer while i am trying to connect the dhcp server to pc it will getting the error like dhcp failed. APIPA is being used.
For this issues this is also one reason.dhcp is not configured correctly.
If we create a vlan's in the switch's and we configured dhcp server in the layer 3 switch or layer 2 switch or in router.
VLAN 10
NAME SALES
VLAN 20
NAME DATA
We created two vlan's now creating dhcp server for that
Switch(config)#ip dhcp pool name sales (should be the vlan name. not any other name.)
Switch(Dhcp-config)#network 192.168.10.0 255.255.255.0
Switch(dhcp-config)#default-router 192.168.10.1
Switch(dhcp-config)#exit
Swithc(config)#ip dhcp pool name data
Switch(dhcp-config)#network 192.168.20.0 255.255.255.0
Switch(dhcp-config)#default-router 192.168.20.1
Switch(dhcp-config)#exit
Bro I am facing same problem,,
ReplyDeleteHello Sharan Kumar! I hope you were able to fix your issue, if not lemme show you an example how to configure DHCP and a gift lol how to configure Voip at the same router.
ReplyDeleteip dhcp excluded-address 172.16.1.1 172.16.1.9
ip dhcp excluded-address 172.16.2.1 172.16.2.9
!
ip dhcp pool DATA_SCOPE
network 172.16.2.0 255.255.255.0
default-router 172.16.2.1
dns-server 4.2.2.2
ip dhcp pool VOICE_SCOPE
network 172.16.1.0 255.255.255.0
default-router 172.16.1.1
option 150 ip 172.16.1.1
dns-server 4.2.2.2
interface FastEthernet0/0.100
encapsulation dot1Q 100
ip address 172.16.1.1 255.255.255.0
!
interface FastEthernet0/0.200
encapsulation dot1Q 200
ip address 172.16.2.1 255.255.255.0
Remember you need to create two subinterfaces for VLANs, it's mandatory you define the encapsulation, if you don't you happen to get the APIPA IP instead of the pool.
From the switch side
interface FastEthernet0/1
switchport mode trunk
// this interface is connected to the router interface fa0/0
We need to create the VLANs DATA and VOICE to join the interfaces
use the option : interfaces range fa0/2 - 24 to add the interfaces to both vlans voice and data the result will something like this:
interface FastEthernet0/2
switchport access vlan 200
switchport mode access
switchport voice vlan 100
!
interface FastEthernet0/3
switchport access vlan 200
switchport mode access
switchport voice vlan 100
You can use the spanning-tree portfast together.
In case of you don't wanna configure voip just skip the voice option and use only the DHCP DATA. Lemme know if you need more tips. Cheers
Thank you!!!
DeleteIf your IP dhcp is wrong and how do you fix it?
ReplyDeleteyou need to check the DHCP configuration on your router. IP subnet, mask, excluded IP and so on. If you can, you put your config here,
ReplyDelete